Несколько уязвимостей в TeamSpeak Server

Дата публикации:
16.05.2007
Всего просмотров:
2736
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4529
CVE-2007-4530
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TeamSpeak 2.x
Уязвимые версии: TeamSpeak 2.0.20.1, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и повысить свои привилегии в приложении.

1. Уязвимость существует из-за того, что приложение позволяет Server Admin назначать зарегистрированным определенные привилегии, такие как "AccessWebAdminServer", "AdminAddServer", "AdminDeleteServer", "AdminStartServer" и "AdminStopServer". Злоумышленник может, запросив непосредственно определенные административные страницы, создавать, запускать, останавливать и удалять сервера. Для удачной эксплуатации злоумышленнику требуется доступ с привилегиями Server Admin.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "error_title" и "error_text" в сценарии error_box.html и в параметре "ok_title" в сценарии ok_box.html. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.goteamspeak.com/downloads.php

Решение: Установите последнюю версию (2.0.23.15 BETA) с сайта производителя.

или введите имя

CAPTCHA