Множественные уязвимости в MonAlbum

Дата публикации:
15.05.2007
Дата изменения:
02.01.2008
Всего просмотров:
1368
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Monalbum 0.x
Уязвимые версии: MonAlbum 0.8.7, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценарии admin/admin_configuration.php перед сохранением данных в файл conf/config.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "glangage" в сценарии admin/admin_configuration.php. Удаленный пользователь может с помощью специально сформированного запроса просмотреть содержимое произвольных файлов на системе.

3. Уязвимость существует из-за недостаточного ограничения доступа к сценарию admin/admin_configuration.php. Удаленный пользователь может запросить уязвимый сценария и получить доступ к конфигурационным данным приложения (например, логин административного пользователя и пароль).

URL производителя: www.3dsrc.com/monalbum/

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

02.01.2008
Изменено название уязвимости
Добавлено описание уязвимостей #2 и #3.
Добавлен PoC код.

Ссылки: Monalbum 0.8.7 Remote Code Execution Exploit
MonAlbum 0.87 Upload Shell / Password Grabber Exploit

или введите имя

CAPTCHA