Переполнение буфера в Apple Darwin Streaming Server

Дата публикации:
14.05.2007
Всего просмотров:
1028
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-0748
CVE-2007-0749
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Darwin Streaming Server 4.x
Darwin Streaming Server 5.x
Уязвимые версии: Apple Darwin Streaming Server 5.5.4 и 4.1, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных в Darwin Streaming Proxy в функции "is_command". Удаленный пользователь может с помощью специально сформированного RTSP запроса вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных в Darwin Streaming Proxy при обработке "trackID" значений в "SETUP" запросе. Удаленный пользователь может с помощью специально сформированного RTSP запроса, содержащего более 32 значений вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: developer.apple.com/darwin/projects/streaming/

Решение: Установите последнюю версию (5.5.5) с сайта производителя.

Ссылки: Apple Darwin Streaming Proxy Multiple Vulnerabilities

или введите имя

CAPTCHA