PHP-инклюдинг в AForum

Дата публикации:
11.05.2007
Дата изменения:
24.03.2009
Всего просмотров:
3933
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-2634
CVE-2007-2596
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AForum 1.x
Уязвимые версии: AForum 1.32, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "CommonAbsDir" в сценарии common/func.php и в параметре "header" в сценарии common/errormsg.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[aforum_path]/common/func.php?CommonAbsDir=[file]

URL производителя: www.agner.org/software/msgbrd2/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA