SQL-инъекция в XOOPS wfquotes

Дата публикации:
07.05.2007
Всего просмотров:
1158
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
wfquotes 1.x (модуль к XOOPS)
Уязвимые версии: wfquotes (модуль к XOOPS) 1.0.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "c" в сценарии modules/wfquotes/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/modules/wfquotes/index.php?op=cat&c=1[sql]

URL производителя: osdn.dl.sourceforge.net/sourceforge/xoops/xoops2-mod_wfquotes_v1_0_0.zip

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA