PHP-инклюдинг в phpChess Community Edition

Дата публикации:
05.05.2007
Дата изменения:
10.04.2009
Всего просмотров:
2322
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpChess Community Edition
phpChess Professional
Уязвимые версии: phpChess Community Edition 2.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "Root_Path" в сценариях skins/phpchess/layout_admin_cfg.php, skins/phpchess/layout_cfg.php и skins/phpchess/layout_t_top.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/example/[ac_path]/spaw/spaw_control.class.php?spaw_root=[file]

URL производителя: www.phpchess.net/index-3.html

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
10.04.2009
Изменена секция "Решение"

или введите имя

CAPTCHA