Переполнение буфера в MailCOPA

Дата публикации:
03.05.2007
Всего просмотров:
1692
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MailCOPA 8.x
Уязвимые версии: MailCOPA 8.01 от 2007-03-23, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке аргументов командной строки. Удаленный пользователь может с помощью слишком длиной (более 1000 байт) ссылки "mailto" вызвать переполнение стека и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости пользователь должен нажать на специально сформированную ссылку и MailCOPA должен быть почтовым клиентом по умолчанию.

URL производителя: www.mailcopa-emailsoftware.com

Решение: Установите последнюю версию (8.01 от 2007-05-01 или выше) с сайта производителя.

www.intervations.com/download/mailcopa/_mailcpa.exe

или введите имя

CAPTCHA