Несколько уязвимостей в TCExam

Дата публикации:
02.05.2007
Всего просмотров:
990
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-2430
CVE-2007-2431
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TCExam 4.x
Уязвимые версии: TCExam 4.0.011, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольный PHP сценарий на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "SessionUserLang" куки файла в сценарии public/code/index.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "_SERVER[SCRIPT_NAME]" в сценарии public/code/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: tcexam.tecnick.com

Решение: Установите последнюю версию (4.1.000) с сайта

или введите имя

CAPTCHA