SQL-инъекция в PostNuke pnFlashGames

Дата публикации:
30.04.2007
Всего просмотров:
1022
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
pnFlashGames 1.x (модуль к PostNuke)
Уязвимые версии: pnFlashGames (модуль к PostNuke) 1.5, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "cid" в сценарии index.php (когда "module" установлен в "pnFlashGames" и "func" в "view"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/index.php?module=pnFlashGames&func=view&cid=[SQL]

URL производителя: www.pnflashgames.com/module-Pagesetter-viewpub-tid-3-pid-0.phtml

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA