Переполнение буфера в Imager

Дата публикации:
30.04.2007
Всего просмотров:
818
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Imager 0.x
Уязвимые версии: Imager версии до 0.57.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке сжатых 8Bit BMP файлов. Удаленный пользователь может с помощью специально сформированного BMP файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: imager.perl.org

Решение: Установите последнюю версию (0.57) с сайта производителя.

или введите имя

CAPTCHA