Переполнение буфера в IrfanView Formats Plug-in

Дата публикации:
30.04.2007
Дата изменения:
01.05.2007
Всего просмотров:
1032
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1867
CVE-2007-1948
CVE-2007-2363
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IrfanView Formats Plug-in 4.x
Уязвимые версии: IrfanView Formats Plug-in 4.0.0.0, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в Formats плагине (Formats.dll) при обработке IFF файлов. Удаленный пользователь может с помощью специально сформированного IFF файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.irfanview.com/plugins.htm

Решение: Установите последнюю версию (4.01) с сайта производителя.
www.irfanview.net/plugins/formats_401.zip

Ссылки: IrfanView Formats Plug-in <= 4.0.0.0 .IFF File Buffer Overflow Exploit

или введите имя

CAPTCHA