Повышение привилегий в PostgreSQL

Дата публикации:
24.04.2007
Всего просмотров:
1845
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PostgreSQL 7.x
PostgreSQL 8.x
Уязвимые версии: PostgreSQL 7.x, 8.x

Описание:
Уязвимость позволяет удаленному пользователю повысить свои привилегии в приложении.

Уязвимость существует из-за ошибки в функциях SECURITY DEFINER. Удаленный авторизованный пользователь может повысить свои привилегии в приложении путем изменения search_path и используя временные объекты.

URL производителя: www.postgresql.org

Решение: Установите последнюю версию (8.2.4, 8.1.9, 8.0.13, 7.4.17 или 7.3.19) с сайта производителя.

или введите имя

CAPTCHA