Переполнение буфера в продуктах ACDSee

Дата публикации:
23.04.2007
Дата изменения:
24.03.2009
Всего просмотров:
1950
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ACDSee Pro 8.x
ACDSee Photo Editor 4.x
ACDSee 9.x
Уязвимые версии:
ACDSee Pro 8.1 Build 99 и более ранние версии.
ACDSee 9.0 и более ранние версии.
ACDSee Photo Editor 4.0 Build 195 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке XPM файлов в "ID_X.apl" плагине. Удаленный пользователь может с помощью специально сформированного XPM файла, содержащего слишком длинную строку section (более 4096 байт) вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.acdsee.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: ACDSee 9.0 (.XPM File) Local Buffer Overflow Exploit

или введите имя

CAPTCHA