PHP-инклюдинг в Opensurveypilot

Дата публикации:
23.04.2007
Всего просмотров:
1448
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Opensurveypilot 1.x
Уязвимые версии: Opensurveypilot 1.2.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "cfgPathToProjectAdmin" и "cfgPathToConf" в сценарии administration/user/lib/group.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/opensurveypilot/administration/user/lib/group.inc.php?cfgPathToProjectAdmin=[file]

URL производителя: www.opensurveypilot.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA