Отказ в обслуживании в lighttpd

Дата публикации:
18.04.2007
Дата изменения:
07.03.2008
Всего просмотров:
1082
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1869
CVE-2007-1870
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
lighttpd 1.x
Уязвимые версии: lighttpd версии до 1.4.15.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести отказ в обслуживании приложения.

1. Уязвимость существует из-за ошибки при обработке последовательностей символов "\r\n\r\n". Удаленный пользователь может с помощью специально сформированного запроса вызвать зацикливание приложения и потребить все доступные ресурсы на системе.

2. Разыменование нулевого указателя существует при обработке mtime в файлах. Удаленный пользователь может с помощью специально сформированного файла с mtime равным 0 аварийно завершить работу приложения.

URL производителя: lighttpd.net

Решение: Установите последнюю версию (1.4.15) с сайта производителя.

или введите имя

CAPTCHA