PHP-инклюдинг в Weatimages

Дата публикации:
14.04.2007
Дата изменения:
24.03.2009
Всего просмотров:
1686
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Weatimages 1.x
Уязвимые версии: Weatimages 1.7.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "ini[langpack]" в сценарии index.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/projects/weatimages/demo/index.php?ini[langpack]=[file]

URL производителя: www.hotscripts.com/jump.php?listing_id=52592&jump_type=1

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA
1
15-04-2007 07:14:11
Это бага не в движке. А бага только в демке (которой нет в архиве двига) - демка только на сайте автора, и дырку он, кстати, до сих пор ни прикрыл...
0 |