Несколько уязвимостей в WordPress

Дата публикации:
10.04.2007
Всего просмотров:
1525
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1893
CVE-2007-1897
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
Уязвимые версии: WordPress 2.1.2, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения и обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в методе "mt.setPostCategories" в сценарии xmlrpc.php. Удаленный авторизованный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной проверки аутентификации в сценарии xmlrpc.php. Удаленный авторизованный пользователь с привилегиями контрибьютора может опубликовать сообщения.

URL производителя: wordpress.org

Решение: Установите последнюю версию (2.1.3) с сайта производителя.

или введите имя

CAPTCHA