Уязвимость в функции unserialize() в PHP

Дата публикации:
26.03.2007
Дата изменения:
28.01.2008
Всего просмотров:
3056
Опасность:
Низкая
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1649
CVE-2007-1885
CVE-2007-1886
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 5.2.x
Уязвимые версии: PHP 5.2.1

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным на системе.

Уязвимость существует из-за ошибки в функции "unserialize()" при обработке строковых типов данных. Злоумышленник может получить доступ к некоторым участкам динамической памяти на системе.

URL производителя: www.php.net

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:

28.01.2008
Изменена секция «Решение».

Ссылки: PHP 5.2.1 unserialize() Local Information Leak Exploit
http://www.php-security.org/MOPB/MOPB-29-2007.html

или введите имя

CAPTCHA