Несколько уязвимостей в OpenOffice

Дата публикации:
22.03.2007
Дата изменения:
18.09.2007
Всего просмотров:
3075
Опасность:
Высокая
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-0002
CVE-2007-0238
CVE-2007-0239
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenOffice 1.1.x
OpenOffice 1.0.x
OpenOffice.org 2.x
Уязвимые версии:
OpenOffice.org 2.x
OpenOffice 1.1.x
OpenOffice 1.0.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Несколько уязвимостей обнаружены в библиотеке libwpd. Удаленный пользователь может с помощью специально сформированного WordPerfect файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе. Подробная информация об узявимости:
www.securitylab.ru/vulnerability/292837.php

2. Уязвимость существует из-за ошибки проверки границ данных в парсере StarCalc. Удаленный пользователь может с помощью специально сформированного документа вызвать переполнение стека и выполнить произвольный код на целевой системе.

3. Уязвимость существует из-за недостаточной обработки консольных метаданных. Удаленный пользователь может с помощью специально сформированного документа или ссылки выполнить произвольные команды на системе.

URL производителя: www.openoffice.org

Решение: Установите последнюю версию 2.2 с сайта производителя.

Ссылки: Multiple Vendor libwpd Multiple Buffer Overflow Vulnerabilities

или введите имя

CAPTCHA