Переполнение буфера в FrontBase Relational Database Server

Дата публикации:
21.03.2007
Дата изменения:
28.01.2008
Всего просмотров:
856
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FrontBase Relational Database Server 4.x
Уязвимые версии: FrontBase Relational Database Server 4.2.7 , возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке аргументов, передаваемых SQL команде "create procedure". Удаленный пользователь может с помощью слишком длинной строки вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.frontbase.com/cgi-bin/WebObjects/FrontBase

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA