Переполнение буфера в расширении Interbase в PHP

Дата публикации:
20.03.2007
Дата изменения:
28.01.2008
Всего просмотров:
993
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.4.x
PHP 5.2.x
Уязвимые версии: PHP 4.4.6, 5.2.1, возможно другие версии.

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке аргументов, передаваемых функции "isc_attach_database()" в библиотеке GDS32.DLL. Локальный пользователь может с помощью слишком длинного аргумента (более 260 байт), передаваемого функциям "ibase_connect()" или "ibase_pconnect()", вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.php.net

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA