Межсайтовый скриптинг в IMP

Дата публикации:
19.03.2007
Дата изменения:
19.03.2007
Всего просмотров:
849
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IMP Webmail Client 4.x
Уязвимые версии: IMP 4.1.3, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за ошибки при обработке поля "Subject" в email сообщениях в сценарии thread.php. Удаленный пользователь может с помощью специально сформированного email сообщения выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "edit_query" и в других параметрах в сценарии search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: horde.org/imp/

Решение: Установите последнюю версию (4.1.4) с сайта производителя.

или введите имя

CAPTCHA