Уязвимость при обработке сессий в PHP

Дата публикации:
16.03.2007
Дата изменения:
28.01.2008
Всего просмотров:
1996
Опасность:
Низкая
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1521
CVE-2007-1522
Вектор эксплуатации:
Локальная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 5.0.x
PHP 4.4.x
PHP 5.1.x
PHP 5.2.x
Уязвимые версии: PHP 5.2.0, 5.2.1, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют локальному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки двойного освобождения памяти в функции "session_regenerate_id()". Злоумышленник может выполнить произвольный код на целевой системе с привилегиями PHP интерпретатора.

2. Уязвимость существует из-за ошибки двойного освобождения памяти при обработке отвергнутых сессий. Злоумышленник может выполнить произвольный код на целевой системе с привилегиями PHP интерпретатора.

URL производителя: www.php.net

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:

28.01.2008
Изменена секция «Решение».

или введите имя

CAPTCHA