Переполнение буфера в функции "snmpget()" в PHP

Дата публикации:
14.03.2007
Дата изменения:
28.01.2008
Всего просмотров:
1704
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1413
CVE-2007-1711
Вектор эксплуатации:
Локальная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.4.x
Уязвимые версии: PHP 4.4.6, возможно более ранние версии.

Описание:
Уязвимость позволяет локальному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "snmpget()". Локальный пользователь может вызвать переполнение стека, обойти ограничение директивы "disable_functions" и выполнить произвольный код на целевой системе.

URL производителя: www.php.net

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA