Переполнение буфера в PECL zip Extension

Дата публикации:
13.03.2007
Всего просмотров:
1649
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PECL zip Extension 1.x
Уязвимые версии: PECL zip Extension версии до 1.8.4.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке "zip:" ссылок. Удаленный пользователь может с помощью слишком длинной "zip:" строки, переданной обработчику ссылок, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: pecl.php.net/package/zip/

Решение: Установите последнюю версию (1.8.4) с сайта производителя.

Ссылки: http://www.php-security.org/MOPB/MOPB-16-2007.html

или введите имя

CAPTCHA