Обход каталога в SQL-Ledger

Дата публикации:
13.03.2007
Всего просмотров:
819
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1540
CVE-2007-1541
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SQL-Ledger 2.x
Уязвимые версии: SQL-Ledger версии до 2.6.25.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных, передаваемых в качестве параметра файла в текстовый редактор. Удаленный пользователь может с помощью специально сформированного параметра, содержащего символы обхода каталога, может получить доступ к произвольным файлам на системе и выполнить произвольный код.

2. Уязвимость существует из-за ошибки в стандартных функциях приложения и может быть использована для выполнения произвольного кода, перезаписи определенных файлов в директории пользователя или обхода процесса аутентификации.

Для успешной эксплуатации обеих уязвимостей злоумышленнику требуется валидная учетная запись.

URL производителя: www.sql-ledger.org

Решение: Установите последнюю версию (2.6.25) с сайта производителя.

или введите имя

CAPTCHA