Переполнение буфера в Ipswitch IMail Server/Collaboration Suite

Дата публикации:
12.03.2007
Дата изменения:
27.02.2008
Всего просмотров:
1373
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ipswitch Collaboration Suite 2006 Premium
Уязвимые версии:
Ipswitch Collaboration Suite 2006
IMail Server 2006

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в IMAILAPI.DLL ActiveX компоненте при обработке членов WebConnect и Connect в IMAILAPILib.IMailServer, Sync3 и Init3 компонента IMAILAPILib.IMailLDAPService, и в SetReplyTo компонента IMAILAPILib.IMailUserCollection. Удаленный пользователь может с помощью специально сформированного Web сайта вызвать переполнение динамической памяти или переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.ipswitch.com

Решение: Установите исправление с сайта производителя.

Версия 2006.2 (только Standard Edition):
ftp://ftp.ipswitch.com/Ipswitch/Product_Downloads/ICS_Standard.exe

Ссылки: Ipswitch IMail Server 2006 Multiple ActiveX Control Buffer Overflow Vulnerabilities

или введите имя

CAPTCHA