Некорректное использование GnuPG в Evolution

Дата публикации:
12.03.2007
Дата изменения:
11.03.2007
Всего просмотров:
911
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1266
CVE-2007-1263
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNOME Evolution 2.x
Уязвимые версии: Evolution 2.8.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за того, что приложение не вызывает GnuPG с опцией "--status-fd" при проверке подписи. Злоумышленник может внедрить произвольные данные в подписанное сообщение.

URL производителя: www.gnome.org/projects/evolution/

Решение: Рекомендуется проверять подписи к сообщениям вручную.

Ссылки: GnuPG and GnuPG clients unsigned data injection vulnerability

или введите имя

CAPTCHA