Переполнение буфера в MSSQL расширении в PHP

Дата публикации:
08.03.2007
Дата изменения:
28.01.2008
Всего просмотров:
2267
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.4.x
PHP 5.2.x
Уязвимые версии:
PHP 4.4.6
PHP-5.2.1 win32 installer

Описание:
Уязвимость позволяет локальному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке аргументов функции "dbopen()" в NTWDBLIB.DLL, расположенной в директории PHP при установленном расширении MSSQL. Злоумышленник может с помощью слишком длинной строки (более 260 байт), передаваемой функциям "mssql_connect()" или "mssql_pconnect()" вызвать переполнение стека, обойти ограничения директивы "disable_functions" и выполнить произвольный код на целевой системе.

URL производителя: www.php.net

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA