Выполнение произвольных команд в WordPress

Дата публикации:
08.03.2007
Всего просмотров:
2984
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
Уязвимые версии: WordPress версии до 2.1.2.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ix" в сценарии wp-includes/feed.php перед вызовом функции "eval()". Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "iz" в сценарии wp-includes/theme.php. Удаленный пользователь может выполнить произвольные команды на системе с привилегиями Web сервера.

URL производителя: wordpress.org

Решение: Установите последнюю версию (2.1.2) с сайта производителя.

или введите имя

CAPTCHA