Переполнение буфера в WebMod

Дата публикации:
05.03.2007
Дата изменения:
07.05.2008
Всего просмотров:
1846
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WebMod 0.x
Уязвимые версии: WebMod 0.x (плагин к Half-Life Dedicated Server)

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "connectHandle()" при обработке HTTP заголовка "Content-Length". Удаленный пользователь может послать специально сформированный HTTP запрос целевому серверу, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: djeyl.net/w.php

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: WebMod Stack Buffer Overflow

или введите имя

CAPTCHA