Множественные уязвимости в PhotoStand

Дата публикации:
01.03.2007
Дата изменения:
13.04.2009
Всего просмотров:
976
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-1101
CVE-2007-1102
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PhotoStand 1.x
Уязвимые версии: PhotoStand 1.2.0, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, обойти ограничения безопасности и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в полях "name" и "comment" при публикации комментария и в параметре "q" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в base64 кодированном параметре "PS_SAVE" файла куки в сценарии admin/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за того, что приложение разрешает доступ к административному интерфейсу при наличии определенного параметра в файле куки. Удаленный пользователь может установить параметр "PS-SAVE" файла куки в base64 кодированное имя действительной учетной записи и получить административный доступ к приложению.

URL производителя: www.photostand.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

13.04.2009
Изменено описание уязвимости, повышен рейтинг опасности, добавлен PoC код.

Ссылки: PhotoStand 1.2.0 Remote Command Execution Exploit

или введите имя

CAPTCHA