PHP-инклюдинг в CS-Gallery

Дата публикации:
01.03.2007
Дата изменения:
14.03.2007
Всего просмотров:
1149
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CS-Gallery 2.x
Уязвимые версии: CS-Gallery 2.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "album" в сценарии index.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP и параметр "todo" должен быть установлен в "securealbum".

URL производителя: www.cschneider.info

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: CS-Gallery 2.0 (index.php album) Remote File Include Exploit

или введите имя

CAPTCHA