Множественные уязвимости в Cisco Firewall Services Module

Дата публикации:
16.02.2007
Всего просмотров:
1982
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-0963
CVE-2007-0964
CVE-2007-0965
CVE-2007-0966
CVE-2007-0967
CVE-2007-0968
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Cisco Firewall Services Module (FWSM) 3.x
Уязвимые версии: Cisco Firewall Services Module (FWSM) 3.x, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и вызвать отказ в обслуживании.

1. Уязвимость существует из-за неизвестной ошибки при расширенной проверке HTTP трафика. Удаленный пользователь может с помощью специально сформированного HTTP запроса вызвать перезагрузку устройства.

2. Уязвимость существует из-за ошибки при проверке SIP пакетов. Удаленный пользователь может послать специально сформированный SIP пакет и вызвать перезагрузку устройства. Для успешной эксплуатации уязвимости опция "SIP fixup" должна быть включена (значение по умолчанию).

3. Уязвимость существует из-за неизвестной ошибки при обработке HTTPS запросов. Удаленный пользователь может с помощью специально сформированного HTTPS запроса вызвать перезагрузку устройства. Для успешной эксплуатации уязвимости "authentication for network access" (auth-proxy) должен быть включен.

4. Уязвимость существует из-за ошибки при обработке HTTP запросов, содержащих слишком длинный URL. Удаленный пользователь может с помощью специально сформированного HTTP запроса вызвать перезагрузку устройства. Для успешной эксплуатации уязвимости "authentication for network access" (auth-proxy) должен быть включен.

5. Уязвимость существует из-за ошибки при обработке HTTPS трафика, направленного FWSM. Удаленный пользователь может с помощью специально сформированного HTTPS запроса вызвать перезагрузку устройства. Для успешной эксплуатации уязвимости HTTPS сервер должен быть запущен на целевом устройстве.

6. Уязвимость существует из-за ошибки при обработке SNMP запросов, полученных от доверенного хоста. Удаленный пользователь может с помощью специально сформированного SNMP запроса вызвать перезагрузку устройства.

7. Уязвимость существует из-за ошибки при обработке списков доступа (Access Control Lists), использующих группы объектов. Некорректное применение административным пользователем списков доступа может привести к тому, что ACE (Access Control Entries) будут пропущены или учтены не в том порядке, что может позволить злоумышленнику обойти некоторые ограничения безопасности.

URL производителя: www.cisco.com

Решение: Установите последнюю версию с сайта производителя.

Ссылки: Cisco Security Advisory: Multiple Vulnerabilitiesin Firewall Services Module

или введите имя

CAPTCHA