SQL-инъекция в PollMentor

Дата публикации:
16.02.2007
Всего просмотров:
1384
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PollMentor 2.x
Уязвимые версии: PollMentor 2.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "id" в сценарии pollmentorres.asp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/[script-path]/pollmentorres.asp?id=-1+UPDATE+poll+SET+question='HekId';--

URL производителя: www.aspcode.net/articles/l_en-US/t_default/Applications/ASPscripts/PollMentor/category_43.aspx

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA