PHP-инклюдинг в OPENi-CMS Seitenschutz

Дата публикации:
13.02.2007
Дата изменения:
13.02.2007
Всего просмотров:
1388
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Seitenschutz (plugin for OPENi-CMS) 1.x
Уязвимые версии: Seitenschutz (плагин к OPENi-CMS) 1.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "config[oi_dir]" в сценарии index.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/open-admin/plugins/site_protection/index.php?config%5boi_dir%5d=[file]

URL производителя: www.openi-cms.org/oi-start.php/start/3_download/3_3_plugins/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Openi CMS plugins (site protection) remote file inclusion

или введите имя

CAPTCHA