Межсайтовый скриптинг и SQL-инъекция в VirtueMart

Дата публикации:
08.02.2007
Дата изменения:
10.02.2009
Всего просмотров:
3656
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-6945
CVE-2007-0376
CVE-2007-1096
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VirtueMart 1.x
Уязвимые версии: VirtueMart 1.0.7, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: virtuemart.net

Решение: Установите последнюю версию (1.0.8) с сайта производителя.

Ссылки: http://sourceforge.net/forum/forum.php?forum_id=647996

или введите имя

CAPTCHA