PHP-инклюдинг в phpEventMan

Дата публикации:
06.02.2007
Дата изменения:
24.03.2009
Всего просмотров:
3374
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpEventMan 1.x
Уязвимые версии: phpEventMan 1.0.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "level" в сценарии Shared/controller/text.ctrl.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/script_pat/Shared/controller/text.ctrl.php?level=[file]

URL производителя: www.dynamicvisions.de/cms/website.php?id=/de/projekte/eventman/index.htm

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA