Межсайтовый скриптинг и SQL-инъекция в Enthusiast

Дата публикации:
24.01.2007
Дата изменения:
11.11.2008
Всего просмотров:
1121
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-0483
CVE-2007-0484
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Enthusiast 3.x
Уязвимые версии: Enthusiast 3.1, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "cat" в сценариях show_owned.php и show_joined.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценариях show_owned.php и show_joined.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: scripts.indisguise.org/enthusiast/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA