Несколько уязвимостей в PentaZip

Дата публикации:
19.01.2007
Дата изменения:
24.03.2009
Всего просмотров:
1532
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2482
CVE-2006-5963
CVE-2006-5964
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PentaZip 8.x
PentaSuite-PRO 8.x
Уязвимые версии:
PentaZip 8.5.1.190, возможно другие версии
PentaSuite-PRO 8.5.1.221, возможно другие версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных в компоненте TZipTV во время просмотра списка файлов в ARJ архиве. Удаленный пользователь может с помощью специально сформированного ARJ архива, содержащего слишком длинный блок заголовка, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки входных данных при распаковке различных архивов. Удаленный пользователь может с помощью символов обхода каталога распаковать содержимое архива в произвольную директорию на целевой системе.

3. Уязвимость существует из-за ошибки в choShilA.bpl. Приложение может аварийно завершить свой работу, если пользователь нажмет правую кнопку мыши на файле со слишком длинным именем.

URL производителя: www.pentazip.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA