Переполнение буфера в libgtop2

Дата публикации:
16.01.2007
Дата изменения:
16.01.2007
Всего просмотров:
1027
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libgtop2 2.x
Уязвимые версии: libgtop2 версии до 2.14.6.

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "glibtop_get_proc_map_s()" в файле sysdeps/linux/procmap.c. Злоумышленник может вызвать переполнение стека и повысить свои привилегии на системе.

URL производителя: www.gnome.org

Решение: Установите последнюю версию (2.14.6) с сайта производителя.

Ссылки: stack overflow in sysdeps/linux/procmap.c: glibtop_get_proc_map_s()

или введите имя

CAPTCHA