Уязвимость при обработке HTTP запросов в libsoup

Дата публикации:
16.01.2007
Всего просмотров:
811
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libsoup 2.x
Уязвимые версии: libsoup версии до 2.2.99.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки в функции "soup_headers_parse()" в файле soup-headers.c. Удаленный пользователь может с помощью специально сформированного HTTP запроса аварийно завершить работу приложения, использующего уязвимую библиотеку.

URL производителя: live.gnome.org/LibSoup/

Решение: Установите последнюю версию с сайта производителя.

Ссылки: [DSA 1248-1] New libsoup packages fix denial of service

или введите имя

CAPTCHA