Уязвимость при обработке неинициализированных указателей в Kerberos kadmind

Дата публикации:
11.01.2007
Всего просмотров:
2028
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Kerberos 5.x
Уязвимые версии: Kerberos krb5-1.5 - krb5-1.5.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки при обработке неинициализированных указателей когда интерфейс "mechglue" в реализации GSS-API вызывает определенные функции обработки ошибок. Удаленный пользователь может с помощью специально сформированного пакета вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

URL производителя: web.mit.edu/kerberos/www/

Решение: Установите последнюю версию с сайта производителя.

web.mit.edu/kerberos/advisories/2006-003-patch.txt

Ссылки: kadmind (via GSS-API mechglue) frees uninitialized pointers

или введите имя

CAPTCHA