Межсайтовый скриптинг и SQL-инъекция в WordPress

Дата публикации:
09.01.2007
Всего просмотров:
2302
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
Уязвимые версии: WordPress 2.0.5, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки кодированных входных данных (например UTF-7), передаваемых функционалу trackback. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости расширение "mbstring" должно быть включено.

2. Уязвимость существует из-за недостаточной обработки входных данных в административном интерфейсе. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: wordpress.org

Решение: Установите последнюю версию (2.0.6) с сайта производителя.

Ссылки: WordPress CSRF Protection XSS Vulnerability
WordPress Trackback Charset Decoding SQL Injection Vulnerability

или введите имя

CAPTCHA