Межсайтовый скриптинг в WordPress

Дата публикации:
02.01.2007
Дата изменения:
02.01.2007
Всего просмотров:
2404
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
Уязвимые версии: WordPress 2.0.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "file" в сценарии wp-admin/templates.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/wp/wp-admin/templates.php?file=%3Cimg%20src='' onerror=javascript:alert(document.cookie);%3E

URL производителя: wordpress.org

Решение: Установите исправление с сайта производителя.

или введите имя

CAPTCHA