PHP-инклюдинг в Pagetool

Дата публикации:
29.12.2006
Дата изменения:
29.12.2006
Всего просмотров:
5343
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-6765
CVE-2007-3402
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Pagetool 1.x
Уязвимые версии: Pagetool 1.07, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "ptconf[src]" в сценарии src/admin/pt_upload.php, когда параметр "config_file" ссылается на существующий файл. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/src/admin/pt_upload.php?config_file=[local server file]&ptconf[src]=[file]

URL производителя: www.pagetool.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA