Переполнение буфера в ядре Linux

Дата публикации:
19.12.2006
Дата изменения:
05.04.2009
Всего просмотров:
2773
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 2.4.x
Linux Kernel 2.6.x
Уязвимые версии:
Linux Kernel версии до 2.4.33.5
Linux Kernel 2.6.x

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании системы.

Уязвимость существует из-за ошибки проверки границ данных при обработке входных CAPI сообщений в файле net/bluetooth/cmtp/capi.c. Злоумышленник может перезаписать определенные структуры данных ядра и вызвать отказ в обслуживании.

URL производителя: www.kernel.org

Решение: Установите последнюю версию (2.4.33.5) с сайта производителя. Для ядра версий 2.6.x рекомендуется отключить поддержку bluetooth.

Ссылки: http://kernel.org/pub/linux/kernel/v2.4/ChangeLog-2.4.33.5

или введите имя

CAPTCHA