PHP-инклюдинг в b2evolution

Дата публикации:
14.12.2006
Всего просмотров:
1000
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
b2evolution 1.x
Уязвимые версии: b2evolution 1.8.5, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "inc_path" в сценарии inc/CONTROL/imports/import-mt.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[b2epath]/inc/CONTROL/import/import-mt.php?basepath=foo&inc_path=[file]

URL производителя: b2evolution.net

Решение: Установите последнюю версию (1.8.6) с сайта производителя.

Ссылки: b2evolution Remote File inclusion Vulnerability

или введите имя

CAPTCHA