Несколько уязвимостей в KDPics

Дата публикации:
12.12.2006
Всего просмотров:
1935
Опасность:
Высокая
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-6516
CVE-2006-6517
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
KDPics 1.x
Уязвимые версии: KDPics 1.16, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "page" в сценарии index.php3 и в параметре "lib_path" в сценариях authenticate.inc.php3 и lib/exifer/exif.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости в параметре "lib_path" опция "register_globals" должна быть включена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "categories" в сценариях index.php3 и galeries.inc.php3. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для удачной эксплуатации уязвимости в сценарии galeries.inc.php3 опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.kdland.org/kdpics/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA