PHP-инклюдинг в awrate.com Message Board

Дата публикации:
11.12.2006
Всего просмотров:
1987
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-6368
CVE-2007-5599
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
awrate.com Message Board 1.x
Уязвимые версии: awrate.com Message Board 1.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "toroot" в сценарии login.php.inc. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/search.php?toroot=[file]
http://[host]/index.php?toroot=[file]

URL производителя: sourceforge.net/projects/awrate/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA